Регистрация
 
Добро пожаловать на форум об электродвигателях!

Актуатор, привязка шага к базе
Прочитано 6655 раз
* 24 Декабря 2007, 15:52:54
Архив, от vladlen30, Отправлено: 03 Июля, 2006 - 15:43:26
Я применил линейный шаговый двигатель (актуатор)для прецизионного перемещения объекта (шаг 12,7 мкм,7,5*/шаг, рабочий ход 2500 шагов ),программа контроллера считает все в числе шагов от точки к точке отстановки.В включенном состоянии все работает с ошибкой в 1 шаг без накопления.В качестве базы нулевой применил выход длинной оси двигателя в упор (пробовал с обеих сторон оси)и оказалось ,что двигатель уходит с упора с потерей до 4 шагов,что неприемлимо.Пока двигатели от HSI серии 2600.Вопрос все ли атуаторы выходят с базы с потерей шагов? Можно ли уменьшить ошибку и чем7 Вы предлагаете похожий актуатор 25BYZ-B03,имеет ли он такую же проблему с выходом с базы?Очень прошу помочь ,Спасибо

Записан
Восстановление тем


* 24 Декабря 2007, 15:53:36
#1
Архив, от Сергей, Отправлено: 03 Июля, 2006 - 15:44:15
Думаю это проблема (постоянная потеря первого шага) не двигателя, а блока управления. При включении блока, до подачи первого импульса "ШАГ", происходит инициализация?

Записан
Восстановление тем


* 24 Декабря 2007, 15:54:28
#2
Архив, от vladlen30, Отправлено: 03 Июля, 2006 - 15:47:43
Да при подаче питания происходит инициализация,но если двигатель стоит не на упоре,он отрабатывает команду один шаг и перемещение оси происходит без ошибки.Если же после инициализации ,и после установки в упрор (базу),подавать команду на один шаг от базы последовательно,измерения показывают,что на первый шаг нет перемещения,на второй- сдвиг на полшага,на третий -полный шаг.Режим управления-полношаговый,включена одна фаза и работает ШИМ по по питанию на TCA3727.

Записан
Восстановление тем


* 24 Декабря 2007, 15:55:10
#3
Архив, от Сергей, Отправлено: 03 Июля, 2006 - 15:48:24
Может быть зто выбирается зазор в паре винт-гайка?

Записан
Восстановление тем